This website is using cookies

Blog

Why can’t I play your apps on my device?

Our apps are not guaranteed to be supported on older devices and operating systems, to ensure that we do not compromise on quality when creating new apps. In particular, we cannot support any Android device running OS 4.0 or earlier. If you have a question about your own device, you can email us at [email protected]

|

Categories

Tags

Archive

Recent